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Notice:  This document contains information on products in the design phase of development. The information here is subject to change without notice. Do not 
finalize a design with this information. 
INFORMATION IN THIS DOCUMENT IS PROVIDED IN CONNECTION WITH INTEL PRODUCTS. NO LICENSE, EXPRESS OR IMPLIED, BY ESTOPPEL OR 
OTHERWISE, TO ANY INTELLECTUAL PROPERTY RIGHTS IS GRANTED BY THIS DOCUMENT. EXCEPT AS PROVIDED IN INTEL'S TERMS AND CONDITIONS OF 
SALE FOR SUCH PRODUCTS, INTEL ASSUMES NO LIABILITY WHATSOEVER AND INTEL DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY, RELATING TO 
SALE AND/OR USE OF INTEL PRODUCTS INCLUDING LIABILITY OR WARRANTIES RELATING TO FITNESS FOR A PARTICULAR PURPOSE, MERCHANTABILITY, 
OR INFRINGEMENT OF ANY PATENT, COPYRIGHT OR OTHER INTELLECTUAL PROPERTY RIGHT. UNLESS OTHERWISE AGREED IN WRITING BY INTEL, THE 
INTEL PRODUCTS ARE NOT DESIGNED NOR INTENDED FOR ANY APPLICATION IN WHICH THE FAILURE OF THE INTEL PRODUCT COULD CREATE A 
SITUATION WHERE PERSONAL INJURY OR DEATH MAY OCCUR. 

Intel may make changes to specifications and product descriptions at any time, without notice. Designers must not rely on the absence or characteristics of any 
features or instructions marked “reserved” or “undefined.” Intel reserves these for future definition and shall have no responsibility whatsoever for conflicts or 
incompatibilities arising from future changes to them. The information here is subject to change without notice. Do not finalize a design with this information.  

This specification, as well as the software described in it, is furnished under license and may only be used or copied in accordance with the terms of the license. 
The information in this document is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by 
Intel Corporation. Intel Corporation assumes no responsibility or liability for any errors or inaccuracies that may appear in this document or any software that 
may be provided in association with this document.  

Intel processor numbers are not a measure of performance. Processor numbers differentiate features within each processor family, not across different 
processor families. See www.intel.com/products/processor_number for details. 

Intel AMT requires the computer system to have an Intel AMT-enabled chipset, network hardware and software, as well as connection with a power source and 
a corporate network connection. Setup requires configuration by the purchaser and may require scripting with the management console or further integration 
into existing security frameworks to enable certain functionality. It may also require modifications of implementation of new business processes. With regard 
to notebooks, Intel AMT may not be available or certain capabilities may be limited over a host OS-based VPN or when connecting wirelessly, on battery 
power, sleeping, hibernating or powered off. For more information, see http://www.intel.com/technology/platform-technology/intel-amt/. 

The Intel® Platform Enablement Test Suite described in this document may contain design defects or errors known as errata— including KVM, AT, IPT, AMT, 
SBA, processor numbering, software source code if applicable—which may cause the product to deviate from published specifications. Current characterized 
errata are available on request.  

Code Names are for use by Intel to identify products, platforms, programs, services, etc. (“products”) in development by Intel that have not been made 
commercially available to the public, i.e., launched or shipped. They are never to be used as “commercial” names for products or intended to function as 
trademarks.  

Contact your local Intel sales office or your distributor to obtain the latest specifications and before placing your product order.  

Copies of documents which have an order number and are referenced in this document, or other Intel literature, may be obtained by calling 1-800-548-4725, 
or by visiting Intel's Web Site. 

Intel, the Intel Logo, Celeron, Pentium, and Atom are trademarks of Intel Corporation in the U.S. and other countries. 

*Other names and brands may be claimed as the property of others. 

Copyright © 2019-2020, Intel Corporation. All rights reserved. 
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1 Introduction 
The purpose of this document is to describe the installation of Intel® Platform Enablement Test Suite (Intel® PETS). 

1.1 Overview 
This chapter provides a brief description of the Intel® Platform Enablement Test Suite. It contains the following sections: 

• Introduction to Intel® Platform Enablement Test Suite 

• Package Contents 

• Installation, Setup, and Testing Flow 

 

1.1.1 Introduction to Intel® Platform Enablement Test Suite 
The Intel® Platform Enablement Test Suite is a one-stop GUI application for the comprehensive automated testing of Intel® ME 
firmware. The Intel® Platform Enablement Test Suite automates a large number of the tests in the Compliancy Guide, significantly 
reducing testing time. The Intel® Platform Enablement Test Suite can be used by ODMs, and Intel testing teams. 

The Intel® Platform Enablement Test Suite is run on a testing machine that has access, WLAN, to an Intel® ME System under Test 
(SUT), including its file system. The Intel® Platform Enablement Test Suite executes tests on the SUT and displays the test results, 
clearly indicating the tests that succeeded and those that failed.  

For the tests that require the performance of power-related operations, the Intel® Platform Enablement Test Suite should be 
connected to the SUT through Intel® APS 3.x. 
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The following diagram shows an architectural overview of the Intel® Platform Enablement Test Suite environment

 
Figure 1-1: Testing Environment Diagram 

 

1.1.2 Package Contents 
The package contains the following: 

 •  Intel® PETS application. 

 •  Test Packages (including test sets, XMLs, and local agent). 

 •  Documentation:  

 —  Intel® Platform Enablement Test Suite Installation and User Guide (this document). 

 —  Intel® APS SW User Guide. 

  

1.1.3 Installation, Setup, and Testing Flow 
To be able to use the Intel® Platform Enablement Test Suite, follow these steps: 

1. Check the requirements for the testing machine and for the SUT. For details, see Chapter 2, "System Requirements" 
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2. Install the Intel® Platform Enablement Test Suite on the testing machine. For details, see Chapter 3, "Installation". 

3. Configure the connection of the Intel® Platform Enablement Test Suite with the "System under Test". For details, see 
Chapter 4, "Defining an Intel® Platform for Testing". 

4. Run the “SetupEnvironmentTest” test package to validate all connections and their functionality. For details, see Chapter 
5, "Defining an Intel® Platform for Testing". 

5. Run tests. For details, see Chapter 5, "Running Tests with Intel® Platform Enablement Test Suite". 

6. View Test Results. For details, see Chapter 5.4, "Viewing, Saving, and Sending Test Reports". 

7. Adjust the package parameters of the test package where necessary. For details, see Chapter 6, "Changing Package 
Parameters". 

8. Add unique SPI flash parts specifications to be checked during related tests. For details, see Chapter 7, "Changing 
General Parameters". 
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2 System Requirements 
This chapter describes the requirements for installing and running the Intel® Platform Enablement Test Suite. The following topics 
are included: 

• Requirements for "System Under Test". 

2.1 Requirements for the "System Under Test" 
 

This section describes the requirements for the system you are testing. The following table details the currently supported SUT 
platforms in Intel® PETS.  

Refer to the latest Intel® PETS Release Notes for more information on Intel® PETS versions supporting current and legacy 
platforms. 
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Platform PCH CPU Intel® ME FW Platform version in PETS SUT 
Creation wizard OS Support 

Lakefield (LKF) LKF LKF Intel® CSME 13.30 ME13.30 Windows* 10  
Windows* 10X 

 

The following are requirements of the SUT: 

 •  For Windows*10: 

  Where Console installed need .Net framework (downloadable from http://www.microsoft.com/downloads/).  

 Where Agent installed need both .Net Framework 4.7.2 and .Net core 3.0 (downloadable from 
https://dotnet.microsoft.com/download). 

 •  For Windows*10X : 

 No installation requirements needed  

 •  Intel® CSE drivers (Intel® Management Engine Interface (Intel® MEI),SPD, JHI, iCLS) must be installed on the platform 
from the firmware kit.  

 •  Graphics driver that suits the video card. 

 •  Wireless connection to the network (for applicable platforms only). 

http://www.microsoft.com/downloads/
https://dotnet.microsoft.com/download
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3 Installation 
This chapter describes how to install “Intel® Platform Enablement Test Suite” and the “local agent”. The following topics are 
included: 

 •  Installing Intel® Platform Enablement test Suite 

 •  Installing the Local Agent on Windows*       

 •  Installing the Local Agent on Windows* 10X  

 •  Uninstalling the Local Agent on Windows* 10X 

 •  Installing and Uninstalling Intel® PETS in silent mode 

3.1 Installing Intel® Platform Enablement Test Suite 
1. Verify that the testing computer meets the system requirements. For details, see Testing Machine Requirements.  

2. Make sure you are logged into the testing computer as an Administrator. 

3. Extract the Intel® Platform Enablement Test Suite files to a folder on the testing computer.  

4. Locate and double-click the installation file (<installation package>\Console\PETSConsole.msi) to launch the 
Intel® Platform Enablement Test Suite Install Shield Wizard. 

5. Click “Next” in the Welcome screen. 

6. Click “I accept the terms of the license agreement” and “Next” in the License Agreement screen. 

7. Click “Next” in the Choose Destination Location screen to install Intel® Platform Enablement Test Suite in the default 
installation folder. To install in a different location, click “Change”. The default installation folder is “C:\Program 
files\Intel\Intel(R) Platform Enablement Test Suite”. 

8. Click “Next” in the Setup Type screen. 

9. Click “Install” in the “Ready to Install the Program” screen to begin installing Intel® Platform Enablement Test 
Suite; a progress bar appears showing the status of the installation. 

10. Click “Finish” in the “Install Shield Wizard Complete” screen to exit Intel® Platform Enablement Test Suite Setup 
wizard.  

3.2 Installing the Local Agent on Windows* 10 
The local agent must be installed on each SUT.  

To install the Local Agent: 

1. Put the Intel® Platform Enablement Test Suite files on the SUT in one of the following ways: 

 —  Extract the Intel® Platform Enablement Test Suite files to a folder on the SUT. 

 —  Copy the PETSLocalAgent folder over to the SUT. 

2. Locate and double-click this installation file on the SUT: <installation package>\Agent\PETSLocalAgent.msi 

3. Configure the Windows* Event Viewer to Overwrite events as needed in the following way: 

a. Choose Control Panel > Administrative Tools > Event Viewer to open the Event Viewer. 
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b. Choose Action > Properties to open the Properties dialog. 

c. Select the Overwrite events as needed option and click OK. 

Note:  The Overwrite events as needed option is selected by default in Windows* 7 and Windows* 8 (SUT only). 

3.3 Installing the Local Agent on Windows* 10X 

3.3.1 To install the Local Agent: 

 

1. Under Intel® PETS build find “PETS_Agent_Windows_10X” compressed folder under  “Agent_Windows_10X” folder ,and extract 
its contents 

 

2.  Copy “Agent_Windows_10X” to the SUT using TShell putd command: 

 —  Open-Device <IP-Address> 

 —  cdd data/users/<user-name>/../ 

 —  mkdird PETS_Agent_W10X 

 —  cdd PETS_Agent_W10X 

 —  putd –r  

Note: The command will ask the user to enter the source from which local agent files will be copied, “ PETS_Agent_Windows_10X”path should 
be entered  

 

3. Create a service for PETSLocalAgent by running the following command in SSH: 

“sc.exe create PETSLocalAgent binPath= C:\Data\Users\<user Name>\..\ PETSLocalAgent.exe start=auto 
DisplayName= " Intel(R) Platform Enablement Test Suite Local Agent “ 

4. Start PETSLocalAgent Service by running: 
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“sc.exe start PETSLocalAgent binPath= C:\Data\Users\<user Name>\..\ PETSLocalAgent.exe “ 

 

5. Set failure behavior for PETSLocalAgent Service by running: 

“sc.exe failure PETSLocalAgent reset= 15 actions= restart/6000” 

6. To check if PETSLocalAgent service is running on the system : 

a) Run “Get-Service” command in PowerShell to list all services on SUT and verify their statuses

 

Or run “Get-Service PETSLocalAgent” to get only the service created for PETS Local Agent 

b) “Run Sc.exe query PETSLocalAgent” 
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3.3.2 Check Intel® PETS Connection: 
After making sure that PETS Local Agent is installed successfully on SUT, Install Intel® PETS Console on the controller. 

1. Create a new SUT using the username and password for the user account previously created. 

2. Before testing connectivity make sure to run the following commands in SSH 

a) Enable ME driver: 

 devcon enable "PCI\VEN_8086&DEV_98E0” 

b) Enable pings: 

 netsh advfirewall firewall add rule name="ICMP Allow incoming V4 echo request" protocol=icmpv4:8,any dir=in 
action=allow 

c) Open port for PETS: 

 netsh advfirewall firewall add rule name="DNX Web Server port" dir=in action=allow protocol=TCP localport=12000 
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3.4 Uninstalling the Local Agent on Windows* 10X  

3.4.1 To Uninstall the Local Agent: 

1. To un-install PETS Local Agent, run the following commands via Powershell: 

 —  sc.exe stop PETSLocalAgent 

 —  sc.exe delete PETSLocalAgent 

2. Then related files and folders can be simply deleted from SUT directory where they were placed. 

 

 

3.5 Installing and Uninstalling Intel® PETS in silent mode 
To install Intel® PETS Console in silent mode, navigate to the Console folder in the downloaded Intel® PETS kit and run the 
following command “msiexec /i PETSConsole.msi /qn” , where:             

 •  /i parameter for installing the specified .msi file. 

 •  /qn parameter for a silent installation that displays no user interface. 

To install Intel®  PETS Local Agent in silent mode, navigate to the Agent folder in the downloaded Intel® PETS kit and run 
the following command “msiexec /i PETSLocalAgent.msi /qn” 

Note:  The following dialog appears requesting confirmation from the user only for first time installation of Intel® PETS agent on a 
clean OS: 
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To uninstall Intel® PETS Console in silent mode, navigate to the Console folder in the downloaded Intel® PETS kit and run 
the following command “msiexec /x PETSConsole.msi /qn”, where: 

 •  /x parameter for uninstalling the specified .msi file. 

To uninstall Intel® PETS Agent in silent mode navigate to the Agent folder in the downloaded Intel® PETS kit and run the 
following command “msiexec /x PETSlocalAgent.msi /qn”. 

3.6 Post Installation Verification (Intel® APS) 
After you have installed and set up Intel® Platform Enablement Test Suite with Intel® APS, you can use Intel® APS 
Software to verify that the Intel® APS is properly connected by performing power transitions on the SUT. 
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4 Defining an Intel Platform for 
Testing 
This chapter describes how to define an Intel platform for testing by the Intel® Platform Enablement Test Suite. This must be 
done before running tests on that platform. 

This chapter covers the following topics: 

• Opening Intel® Platform Enablement Test Suite 

• Opening Intel® Platform Enablement Test Suite from the Command Line 

• Defining the Intel® System Under Test 

• Systems Under Test Dialog 

• Testing the SUT Configuration 

To configure Intel® Platform Enablement Test Suite, perform the following: 

1. Open Intel® Platform Enablement Test Suite. 

2. Configure the system under test (SUT) by defining its parameters. 

3. Test the connectivity with the SUT. 

4. Test the setup of the SUT. 

Note:  You should also run the connectivity and setup tests whenever there is a change in the environment (e.g., you select 
another SUT to be tested). 

 

4.1 Opening Intel® Platform Enablement Test Suite 
Choose Start > Programs > Intel > Intel® Platform Enablement Test Suite; the Intel® Platform Enablement Test Suite 
window appears. 

4.2 Opening Intel® Platform Enablement Test Suite from the 
Command Line 

4.2.1 Command line for semi-automated tests 
Using the help option “-?” will list all the supported options:  

o Run and Close. 
o Open package in GUI. 

Follow these guidelines to run those tests using the Command Line: 

1. Open a new command line window as an administrator. 

2. Navigate to the PETS installation director 
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3. Type one of the following commands:  

a. For Run and Close test:  

 Run_PETS.bat -run -package "full package path" -sut "SUT Name in PETS".  

b. For Open package in GUI test: 

 Run_PETS.bat –Open -package "full package path" –sut “SUT Name in PETS". 

Where: 

 The “full package path” is the full path for the package you want to run.  
 The “SUT Name in PETS” is the name of the SUT that you should define in PETS before you run the test. 

This SUT can only be defined in the GUI mode (but not in the command line mode). 

Intel® PETS runs and closes automatically when execution finishes. If all the tests pass, an Exit Code of 0 is returned. If one or 
more tests fail, the Exit Code is 1, and if there is a configuration error, the Exit Code is -1. For example: 

If you have a package on the C drive named tests.xml and you have defined a SUT in PETS with the name skl, then type the 
following command to run your package: Run_PETS.bat -run -package "C:\tests.xml" -sut "SUT". Press <Enter> to begin 
execution. 

4.2.2 Command line for automated tests 
CLI for automated tests runs the tests in silent mode. It can be launched by following these steps: 

1. Open a new command line window as an administrator.  

2. Navigate to Intel® PETS installation directory. 

 

3. Type the following command to get usage: PETSCommandLine.exe -? Or PETSCommandLine.exe –help 

4.2.2.1 The command line syntax for Intel® PETS executable 

 
PETSCommandLine.exe [-? | -help] [-sutimport "SUT file path"] [-suts]  [-sutsettings -sutselect "name of sut"]  [-sutinfo -
sutselect "name of sut"]  [-testconn -sutselect "name of sut"] [-testmeconn -sutselect "name of sut"]  [-getdeepsx -sutselect 
"name of sut"]  [-package "package file path" -tests] [-package "package file path" -teststeps "test name"]  [-package "package 
file path" -tests -sutselect "name of sut" -run] [-package "package file path" -sutselect "name of sut" -runtest "test name"] [-
package "package file path" -sutselect "name of sut" -testcase "test name" -runsubtest "sub test name"][-repeat “number of 
times to run the test”] [-failurebehavior “behavior when test fail”] [-htmllog]  [-spreadsheet] 
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Option Description How to use? 

-?/-help Displays all the arguments supported in PETS CLI. -? Or -help 

-sutimport Imports any SUT file to Intel® PETS. -sutimport "SUT file path" 

-suts Displays all SUTs in the DefaultSut.xml file. -suts 

-sutsettings 
Displays SUT information, platform version, type, SKU and 
network, Intel® ME FW version, Power, and features that are 
enabled. 

-sutsettings -sutselect "SUT Name" 

-sutinfo 
Retrieves the following information about the SUT: Firmware, 
MEBx, LMS, BIOS, MEI Driver, GFX Driver, and Configuration 
State. 

-sutinfo -sutselect "SUT Name" 

-testconn 

Tests the connectivity with Local Agent, that includes: 
1. Ping Local Agent. 
2. Verify communication with Local Agent. 
3. Local agent version matches to PETS version. 

-testconn -sutselect "SUT Name" 

-testmeconn Tests Intel® ME connectivity. -testmeconn -sutselect "SUT Name" 

-getdeepsx Gets the DeepSx configuration from BIOS and saves the setting 
in DefaultSut.xml. -getdeepsx -sutselect "SUT Name" 

-tests(1) Prints all test within the selected package. -package "Path\PackageName.xml" -tests 

-teststeps(1) Prints all test steps within a test in the selected package. -package "Path\PackageName.xml" -teststeps 
"Test Name" 

-run(1) Runs all tests within the selected package. -package "Path\PackageName.xml" -sutselect 
"SUT Name" -run 

-runtest(1) Runs the selected test. -package "Path\PackageName.xml" -sutselect 
"SUT Name" -runtest "Test Name" 

-runsubtest(1) Runs the selected subtest. 
-package "Path\PackageName.xml" -sutselect 
"SUT Name" -testcase "Test Name" -runsubtest 
"SubTest Name" 

-repeat(1) Runs the selected Package/Test/Subtest more than 1 time 
(depends on user decision). 

1.  -package "Path\PackageName.xml" -
sutselect "SUT Name" -run -repeat 2 

2. -package "Path\PackageName.xml" -
sutselect "SUT Name" -runtest "Test 
Name"  -repeat 2 

3. -package "Path\PackageName.xml" -
sutselect "SUT Name" -testcase "Test 
Name" -runsubtest "SubTest Name" -repeat 
2 

-failurebehavior (1) (2) Decides the behavior upon failure of a subtest, a test, a 
package. 

1. -package "Path\PackageName.xml" -
sutselect "SUT Name" -run -failurebehavior 
"NextTest" 

2. -package "Path\PackageName.xml" -
sutselect "SUT Name" -runtest "Test Name" 
-failurebehavior "NextSubTest" 

3. -package "Path\PackageName.xml" -
sutselect "SUT Name" -testcase "Test 
Name" -runsubtest "SubTest Name" -
failurebehavior "NextStep" 

- htmllog (1) (3) (4) Creates the HTML log for the running Package/Test/Subtest. 
-package "Path\PackageName.xml" -sutselect 
"SUT Name" -run -htmllog -logspath 
"Path\LogFolder" 

-spreadsheet (1) (3) (4) Create the spreadsheet for the running Package/ Test/ Subtest. 
-package "Path\PackageName.xml" -sutselect 
"SUT Name" -run -spreadsheet -logspath "Path\ 
LogFolder" 

 
(1) If Path was not provided as "Path\PackageName.xml", write only "PackageName.xml" the path will be the default folder as 

defined in SUT, example: ME\CNL\Windows\Consumer\Mobile\Wired_Only 
(2) -       Failure behaviors supported for running package are: NextStep, NextSubTest, NextIteration, NextTest, Stop 

- Failure behaviors supported for running subtest are: NextStep, NextIteration, Stop 
- Failure behaviors supported for running test are: NextStep, NextSubTest, NextIteration, Stop 

(3) htmllog and –spreadsheet commands can be used together 



Defining an Intel Platform for Testing 

21 

Intel Confidential 

(4) If the path was not provided as "Path\LogFolder”, the logs will be saved in “PETS root\Logs\Log_XMLs”  

4.2.2.2 Exit Codes 

CLI returns 3 exit codes as follows: 

 
0 Test passed/command succeeded 

1 Test Failed 
-1 Error occurred 

4.3 Defining the Intel® System Under Test 
An Intel® SUT is an Intel platform that was defined for testing by the Intel® Platform Enablement Test Suite. In order to run a 
test package: 

 •  An Intel® CSE platform must be defined as a SUT in the Systems Under Test dialog. 

 •  A SUT must be selected for testing from the drop-down list of SUTs in the Intel® Platform Enablement Test Suite window’s 
toolbar’s Platform field ( ). 

You can only test one SUT at a time even if more than one SUT has been defined or imported for testing. The Platform field displays 
the name of the SUT being tested. All the SUTs that are available for testing by Intel® Platform Enablement Test Suite are listed 
in the Platform field’s drop-down list. If the Platform field is empty, a SUT has not yet been defined or imported for testing. 

 If the wrong SUT is displayed in the Platform field, you can select a different SUT from the Platform field’s drop-down list. If the 
correct SUT is not listed there, you can use the Systems Under Test dialog to add or import the correct SUT. The names of all the 
SUTs that have been defined or imported for testing in the Intel® Platform Enablement Test Suite are saved in the default SUT file 
(defaultSut.xml).  
 

4.4 Systems Under Test Dialog 
 
 
You can open the Systems Under Test dialog in the following ways: 

 •  Select SUT Management from the drop-down list in the Platform field. 
 •  Choose Settings > Systems Under Test. 

 •  Click the Platform button (  ) in the toolbar.] 
 

The Systems Under Test dialog has up to seven tabs. Each tab defines a different set of parameters: 
 •  SUT Overview - general data about SUT; Systems Under Test dialog opens to this tab by default. 
 •  General Host Settings - contains the information used by the Intel® Platform Enablement Test Suite to connect to the local 

agent on the SUT. 
 •  Intel® APS Settings - selects and configures the SUT’s power provider. 
 •  Power Settings - power settings of the SUT. 
 •  System Information - displays the SUT’s ME Information. 

 
 
You can do the following in the Systems Under Test dialog: 

 •  Add a new SUT to the Intel® Platform Enablement Test Suite and define its parameters. 
 •  Select an already-defined SUT. 
 •  Import an existing SUT definitions file. 
 •  Redefine the parameters of an already-defined SUT. 
 •  Delete a SUT from Intel® Platform Enablement Test Suite. 
 •  Export the SUT definitions to a file. 
 •  Check if the Intel® Platform Enablement Test Suite is properly connected to the SUT. 
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4.4.1 Adding and Defining a SUT 

To add a SUT and define its security settings: 
1. Open the Systems Under Test dialog. The Systems Under Test wizard opens. 
2. Click the New button. 
3. The SUT Creation Wizard opens to the Description tab. 

 
 

Note:  Simple SUT is appropriate when you want to work with a SUT regardless of its firmware, for example, if your tests are not 
related to a specific firmware feature. Simple SUT is a one-step wizard that only asks for operating system information  
4. Enter data about the SUT into the following fields: 

 —  Name 
 —  Description 

5. Click Next; the following General Host Settings dialog appears: 
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6. Enter data into the following fields: 

 —  User Name: OS user name. 
 —  Password: OS password. 
 —  WLAN IPv4 (WLAN IPV4): IP address of the SUT’s operating system.  
 —  Port Number: The port that the local agent listens on. If this port is used by another application, you need to 

change the port number. To change the local agent’s port number, open the PETSlocalagnet.exe.config file in 
the installation directory and change the address field so it contains the new port number. For example, to 
change the port to 60000, change the address line from <add key="address" 
value="net.tcp://localhost:12000" />  
to <add key="address" value="net.tcp://localhost:60000" /> 
The default port for Windows* is 12000  

 —  WLAN MAC address (WLAN MAC address): WLAN card MAC address for magic packet; either enter manually 
or press Retrieve. 

 —  Test connectivity with Local agent: Clicking this option verifies whether the Intel® Platform Enablement Test 
Suite is able to connect with the PETS local agent on the SUT host and displays a dialog of Local Agent 
Connectivity Results.  
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 —  Test Environment: If checked, on each screen in the SUT wizard flow where these is a test button, the test will 

be run before the Next button flow is executed. If unchecked, at the end of the wizard flow, the System 
Information tab will not be updated with data, until Refresh is pressed. 

Note:  The example screens shown in the following steps are for an ME test platform.  
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7. Click Next; The System Information prompt appears.  

 
 —  Click Retrieve to obtain the system information. 

 
8. Click Next; The Intel® APS dialog appears 
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In the Intel® APS Settings dialog, select the appropriate options to configure the Intel® APS delays. The fields can be understood 
as follows: 

 —  Enable Intel® APS Tracing: 

• When selected, PETS starts logging every change to Intel® APS (e.g. system power state / ME state / Power 
source). The changes are included in the test's execution report. 

 —  Refresh Frequency:  

• This field is enabled when the user checks the "Enable Intel® APS Tracing" option and specifies the time 
period in which PETS will check for APS changes. 

 —  Intel® APS Delays: 

• Short Reset Delay: defines how long the delay takes to perform a Reset (in seconds).  

• Short Power Button Delay: defines how long the delay takes to perform a power button (in seconds).  

• Power Button Override Delay:  

o Default Power Button Override Delay: if it is selected, the power button override delay (in secs) will be 
the default value (APS default value) which is 7. 

o  Set Power Button Override Delay: if it is selected, the power button override delay will be the value that 
the user enters (in seconds). 

 
 

 
9. Click Next; The feature selection dialog appears. In this dialog, select the feature(s) that are enabled on the SUT. 

 

 
 

Note:  The option DC-only Power State is selected by default which causes its related tests to be displayed in Intel® PETS, in case 
the machine does not support this option, it is recommended to uncheck it in order to hide the related tests. 

 
Note:  Pointing the mouse icon at any feature displays a tooltip with a brief description of the selected feature. 

10. Click Finish; the following information screen appears providing current Intel® CSE information for the newly defined 
SUT. 
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11. Click the Save button to save the information entered to the SUT dialog into the Platform information file.  

Note:  The information entered into the dialog only becomes active after being saved. 
12. Click the Close button; the SUT dialog closes and the system prompts you to run the Intel® Platform Enablement Test 

Suite. 

 
13. Click OK; “Run the setup Environment Test” prompt disappears and the Wizard closes. 
14. Run the setup test package to check if the SUT was configured correctly. (For more details, see "Testing the 

Configuration of the SUT".) 

4.4.2 Selecting a Previously-Defined SUT 
The SUTs that are listed in the drop-down list of SUTs at the top of the Systems Under Test dialog have already been defined.  
 
To select an already-defined SUT: 

Select one of the SUTS listed in the drop-down list of SUTS; the values of the parameters of the selected SUT appear in the 
Systems Under Test dialog’s fields, where they can be viewed and changed. 

Note:  If you do not click the Save button before selecting another SUT, any changes you made to the definition of the current 
SUT will be lost. 

 

4.4.3 Modifying the Definitions of a SUT  

You can modify the contents of any field in any tab of the Systems Under Test dialog. 

Note:  You cannot change any of the settings in the Description tab. If you need to change them, delete the SUT and define a new 
SUT with the desired settings. 
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To modify an already-defined SUT: 

1. Select the SUT you want to modify from the drop-down SUT list; the dialog’s fields and tabs are populated with the 
selected SUT’s data.  

2. Make the relevant changes to the contents of the dialog’s fields. 

3. Click Save. 

4.4.4 Saving the SUT Defined Parameters 
After filling in all the relevant fields and tabs in the Systems Under Test dialog: 

1. Click Save to apply all your changes. 

2. Click Close to close the dialog; the names of all of the defined SUTs appear in the Platform field’s drop-down list in 
the Intel® Platform Enablement Test Suite window. 

4.4.5 Importing a SUT Definition File  
1. Click on the Import button; the Import SUT file dialog appears. 

2. Select a SUT file and click Open; the imported SUT is listed in the SUT drop-down list and its definitions appear in the 
Systems Under Test dialog’s fields. 

4.4.6 Deleting a SUT from Intel® Platform Enablement Test Suite 

To delete a SUT from the Intel® Platform Enablement Test Suite: 

1. Select one of the SUTs listed in the drop-down SUT list.  

2. Click the Delete button; then “Are you sure you want to delete this SUT” confirmation prompt appears. 

3. Click Yes; the definitions of the deleted SUT disappear from the Systems Under Test dialog’s fields. 

 

4.4.7 Exporting SUT Definitions to a Definition File 

To export SUT definitions: 
1. Select a SUT listed in the drop-down SUT list. 
2. Click the Export button; the Save As dialog appears. 
3. Enter the name of the definitions file into the File Name field and click Save. 
4. Intel® Platform Enablement Test Suite populates the definitions that you have entered into the Add New SUT dialog. 

4.5 Testing the SUT Configuration  
The Setup Environment test package checks if the SUT was configured correctly. If the SUT passes all the tests in this package, it 
is configured correctly and other test packages can be run on it. If the SUT fails a test, check which test or test step fails in order 
to know how to reconfigure the SUT correctly. 

The setup Environment test package file name is “SetupEnvironmentTest.xml”. Loading and running this test package in Intel® 
Platform Enablement Test Suite Setup has the same procedure of loading and running any other test package. (For more 
information, see "Configuring the Tests in the Test Pane" and "Configuring a Test Package".) 
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Note:  Running the setup environment test package is optional but highly recommended to be run before running other PETS 
general test packages. 

4.5.1 Testing the Configuration of the SUT 

 
Test Name Description 

Local agent and SUT 
connectivity setup 

The test checks connectivity between the console and the local agent (SUT) 
through: 

1. Verifying PETS agent version. 
2. Retrieving ME information from PETS agent. 

Check S0IX Checks modern standby mode 

Check OS Hibernate Checks Hibernate Cycle 

Check OS Shutdown Checks Shutdown Cycle 

Check DC Power Checks the Battary Connectivity to the SUT 

Check AC Power Checks the Power Connectivity to the SUT 

Check G3 State Checks the Power Loss 

OS Configuration Checks Checks the basic Operating System Configurations on MC and the SUT 
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5 Running Tests with Intel® Platform 
Enablement Test Suite 
This chapter describes how to use the Intel® Platform Enablement Test Suite to run tests on an SUT. The 
following topics are included: 

• Configuring a Test Package 

• Viewing Intel® APS Controls 

• Running Tests 

• Viewing, Saving, and Sending Test Reports 

• Using the Compliancy Guide 

 

5.1 Configuring a Test Package 
The Intel® Platform Enablement Test Suite is supplied with one or more test packages. Each test package 
contains the XML files that define its tests. All test packages must be loaded into Intel® Platform Enablement 
Test Suite. Each test package - including its tests and test steps - are already configured with default values that 
can be changed in the Intel® Platform Enablement Test Suite. 
 

5.1.1 Loading a Test Package 

Intel® PETS is able to open the correct packages' sub-folder based on the SUT settings.  

1. Choose Package > Open; the Open Intel® PETS Package dialog appears, displaying the contents of the 
folder <Intel® Platform Enablement Test Suite folder>\Packages> depending on the SUT 
configurations. 

2. Select the test package that is appropriate for the SUT. The name of the selected test package and the 
number of tests it contains appear in the Intel® Platform Enablement Test Suite window above a list of 
tests in the package. 

Note:  The package’s test names map directly to tests that are listed in your platform’s Compliancy Requirements 
and Testing Guide, which contains a detailed description of each test (with the exception of the Validation 
package tests, which do not appear in the Guide). Each Test Name maps to the test ID of a test in the 
Compliancy Requirements and Testing Guide. 

 
 
 
 

5.1.2 Opening a Recent Package 
The Intel® Platform Enablement Test Suite allows you to select a package from a list of the 10 most recently opened packages. 

1. Choose Package > Recent Packages; a list of the 10 most recently opened packages appears. 
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2. Select the package you wish to open from the list. 

5.1.3 Using the Intel® Platform Enablement Test Suite Window  
The Intel® Platform Enablement Test Suite displays the tests in the loaded test package by default. 

 

The Intel® Platform Enablement Test Suite displays the following information about each test/test step: 

 •  Test Name: Name of the test/test step as it appears in the relevant Compliancy Requirements and Testing Guide 

 •  Description: Description of the test/test step’s functionality. The icon next to the description shows what is being tested and 
how: 

•  - Setup test – A test that configures the SUT in preparation for an upcoming test. 
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•  - A test with manual steps. 

 •  Repeat: Number of cycles of test repetition before the next test in the package is to be run (tests only). 

 •  Failure Behavior: How Intel® Platform Enablement Test Suite responds to the failure of a test package,  test, or test step: 

• Next step - If a test step fails, Intel® Platform Enablement Test Suite runs the following step in the test.  

• Next Subtest - If one of the test steps failed and there exists other subtests in the test, the next subtest is 
executed. 

• Next iteration - If a test fails, Intel® Platform Enablement Test Suite runs the next iteration of the same test. If 
the last iteration of the test that fails, Intel® Platform Enablement Test Suite runs the next test.  

• Next test - If a test or test step fails, Intel® Platform Enablement Test Suite runs the next test instead of 
continuing to run any more of the failed test’s test steps or iterations (This is the default failure behavior option 
for test packages).  

• Stop - If a test or test step fails, Intel® Platform Enablement Test Suite stops running that test package. 

• Inherit - Inherits the failure behavior of the level above (i.e., a test inherits the failure behavior of its test 
package and a test step inherits the failure behavior of its test). 

• Manual - Upon failure, choosing this failure behavior will allow the user to control the failure/recovery process by 
showing the following dialog: 

 

The example screen shows the failing test step highlighted in red, and the test steps above and below it as well. The user can 
choose one of the following options: 

- Continue to and select one of the following options: 

o Next Step - The current step is marked as passed with a warning, and the next test step is executed. 

o Next Iteration - The current step is marked as passed with a warning, and the next test iteration is 
executed. 

o Next Test - The current step is marked as passed with a warning, and the next test is executed. 

o Next Subtest - The current step is marked as passed with a warning, and the next subtest is 
executed. 



Running Tests with Intel® Platform Enablement Test Suite 

33 

Intel Confidential 

- Retry: This lets PETS re-run the failing step before proceeding to the next one. If the test step passes after retrial, 
the status will be then passed with warning. Refer to the "Status" section below for more details. The success details 
are added to the PETS Log. 

o The PETS log details all step events, displaying the status of each retry as shown below. 

 

 

- Stop: This will stop the execution of the current test and will run the next test or stop execution if it is the last test 
in the package. 

5.1.3.1 Test’s Status:  
• Not Running - The test has not yet been run. 

•  Iteration indicator - The test is currently running that iteration(e.g., 1/3). 

•  Passed - The test was run successfully. 

•  Failed - The test was run unsuccessfully. 

•     Aborted - The testing process was aborted by the operator. 

•  Paused - The testing process was paused by the operator 
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•  Passed with warnings - This status appears along with the "Manual" failure behavior when the 
test step is failed, retried or continued by the user. 

•      Failed with warnings - This status appears for optional test steps, for example, CheckFWSTS. 

5.1.3.2 Viewing a Test’s Steps: 

To view a test’s steps: 

1. Choose View > Steps Pane; the Intel® Platform Enablement Test Suite window is divided into two panes: 

•   Upper pane - the Test pane - lists all the tests in the test package. Each test has Run, Failure Behavior and Repeat 
options that configure how that test is run.  

•   Lower pane - the Test Step pane - lists all the steps in the test selected in the Test pane (the first test is selected by 
default). Each test step has Run and Failure Behavior options that configure how it is run.  

2. Click on one of the tests listed in the Test pane; the test steps of the selected test are displayed in the lower pane. 

 

 

5.1.3.3 Configuring the Tests in the Test Pane 

To configure the tests in the Test pane: 

1. Verify that the checkbox in the Run column is selected for each test you want to run and deselected for each test you 
do not want to run (The Run checkboxes are selected for all the tests by default). To select or unselect all the tests, 
right-click the heading (Run) and choose Select All or Unselect All. Alternatively, you can select/unselect multiple 
tests/test steps together. 
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2. To change the number of cycles that a test should be performed for, double-click the value in the test’s Repeat column 
and enter the number of cycles.  

3. Click the help icon in the Params column to view and edit package parameters related to the test under which the 
selected test step is nested. 

4. Select one of the following options in the Failure Behavior drop-down list to define what will happen if one of the test’s 
test steps fails: Next step, Next test, Stop, and Inherit. 

Note:  The “Failure Behavior” option provides simultaneous changeability of multiple selected tests.  

 

5.1.3.4 Configuring the Test Steps in the Test Step Pane 

To configure the test steps in the Test Step pane: 

1. Verify that the checkbox in the Run column is selected for each test step you want to run and deselected for each test 
step you do not want to run. To select or unselect all the tests, right-click the heading (Run) and choose Select All or 
Unselect All, respectively. (By default, the Run checkboxes are selected for all of the test steps.) 

2. Select one of the following options in the Failure Behavior drop-down list to define what happens if a test step fails: 
Next step, Next test, Stop, and Inherit. 

Using Group Select/Unselect in Power Packages 

  For Power Packages only, Intel® PETS groups steps into sub-tests, and allows an entire sub-test to be selected or 
unselected. Simply right-click on a test and you will get the following screen (example shown): 

         

You are also able to group select/unselect the relevant test steps with a single command.  
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Using the Right-click menu: 

Open a test in Intel® PETS. 
The steps in the Test Steps (lower) pane will be delineated by a horizontal line. The steps below the horizontal line are the 
Sub Test steps. Right-clicking would open a menu with the following options: 

1. Select Sub Tests: To select all Sub test steps; alternatively, choose Unselect Sub Test to deselect all Sub Test steps. 

2. Select This Test Step And All Steps Below/Above: These options would select the current step and mark either all 
above or below remaining test steps. 

3. Unselect/Select All Test Steps: This will select or unselect all test steps in the current test. 

4. Select All Automated Sub Tests: This will select only automated sub tests of a test. 

Alternatively, users can use hotkeys such as shift or ctrl to select multiple tests. Users can mark the selected test to be 
performed by right-clicking and choosing the Select Test Steps/s option from the menu. 

5. Preview: A preview dialog will display how the test step will look like when it is run. This usually appears for test steps 
that display a message or question to the user as part of the execution. 

Note:  For now, this feature is only available for the Message and Question test steps. The below screenshot shows an example of 
how the preview dialog would look like:  

 

6. Display Description & Troubleshooter: This will activate a dialog that includes the following information: 
 —  The name of test step and last date of modification of the test step’s description and troubleshooter. 
 —  Description tab: This description is usually populated by Intel® PETS developers and reflects the techniques and logic 

behind a specific test step and how it was programmed. As an example, when activating this feature for the 
“BringToBaseState” step, the user will get the following flow chart diagram explaining the process of bringing the SUT to 
the S0 state before running the test.  

 
 —  Troubleshooting tab: This tab contains debug information for the test operation in case of failures. Such as the 

configurations which must be set in order to run the test step without failures. Here is an example for the 
“BringtoBaseState” step Troubleshooter: 
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5.1.3.5 Configuring how a Test Package is run 

To configure how the Test Package is run: 

1. Go to Run>Failure Behavior and select which of the following options will occur if one of the tests in that test package 
fails: Next iteration, Next test, and Stop. 

2. Configure the Package Parameters of the test package. (For information on how to configure package parameters, see 
Changing Package Parameters. 

 

5.1.3.6 Saving the Changed Configuration of a Test Package  
 
You can save the changed configuration of a test package as an original version or as a new version of that package. Either one 
of the versions (original/modified) of the test package can be loaded into the Intel® Platform Enablement Test Suite at a later 
date.  
 
To save the changed configuration of a test package over the original version:  

1. Go to Package > Save  

 
 

Typically, you can use this function when editing an existing package and you wish to save changes as you work (prevent loss of 
information if a crash occurs). Save replaces the original file. 

To save the changed configuration of a test package as a new version:  

1. Choose Package > Save As.  
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You can save the changed configuration of a test package as a new version basing the new package on one you have already 
opened/edited. This is useful if you want to save an existing package with a new name and then make changes rather than start 
from scratch. Save As leaves the original package unchanged.  

 

 

2. Enter the name of the new package in the Name field of the Save As dialog.  

3. Specify the desired location and click Save. The new version of the test package is saved in the desired location.  
 
 

5.2 Viewing APS Controls 

To view PETS Power Provider Controls: 

 

 •  Choose View > APS Controls. 

 

Note:  Intel® Platform Enablement Test Suite must be connected to the SUT via an Intel® APS hardware device that is attached to 
the SUT. The SUT must be defined to be configured with Intel® PETS Power Provider . 

The PETS Power Provider Controls are divided into the following two groups: Power Operations and Power Sources: 

 

I. Power Operations - Control the power transitions of the SUT: 
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• Power On/Off - Turns the power to the SUT on and off by causing the Power button to be pressed on the Intel® 
APS. Power On appears when the SUT is off. Clicking this button turns the power on. Power Off appears when the 
SUT is on. Clicking this button turns the power off. 

• Reset - Restarts the SUT by causing the Reset button on the Intel® APS to be pressed. 

• Clear CMOS - Performs Clear CMOS. A message appears, describing the Clear CMOS operation and prompting the 
user for confirmation. 

 

• Unconditional Power Down - Turns off the SUT by causing the Power button on the Intel® APS to be pressed for 7 
seconds. 

II. Power Sources - Connect or disconnect the SUT from its power source: 

• AC - Connects only the AC power supply to the SUT. 

• ACDC - Connects both the AC and DC power supplies to the SUT. 

• DC - Connects only the DC power supply to the SUT. 

• G3 - Disconnects all power sources from the SUT. 

Note:  When transitioning from AC to ACDC to DC or from DC to ACDC to AC, make sure the SUT remains in ACDC power state for 
7 seconds at least. Otherwise, the SUT may shut down (enters G3 power state). 

Note:  The DC and ACDC options are not available in Desktop platforms and Workstations. 

5.3 Running Tests 
To run a test package:  

 
 Click the Start button or choose Run > Run Package to run the test package’s selected test(s) and test step(s). 

 
Note:  Once the Run button is clicked, you will see a progress window showing that the test operator is synchronizing the time of 

the SUT clock with that of the MC clock. This is done in order to make sure the test's logs will be arranged in the correct 
sequence especially when the test's step event is executed on the SUT.  

To manually stop running a test: 
 Click the Stop button or choose Run > Stop. 

To pause a test while it is being run: 
 Click the Pause button or choose Run > Pause 
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To resume running a paused test: 
 Click the Start button. 

Note:  If a test step is stopped or paused, Intel® Platform Enablement Test Suite does not stop the test immediately but allows it 
to continue until the test step being run has finished. The messages and dialogs that appear as part of that test step will 
continue to appear even though the test step has been stopped/paused. 

5.3.1 Verify Platform Devices Test Step 
Intel® PETS has a new test step named “VerifyPlatformDevices” added at the beginning of each test in most of the testing 
packages to verify platform devices in the device manager. In case the device manager shows unknown devices with a yellow 
bang, or uninstalled devices, or devices in faulty state, the step will fail and be marked as a warning.  Its logs will display a full 
description of the errors.  

 

The user has the choice to either run this test step or skip it by checking/unchecking the following option in the Settings menu-
bar item. However, it is highly recommended to execute it. 

 

5.3.2 Audible notification during testing 
PETS introduces a new feature that provides an alternate method to notify the test operator of the testing status in two 
situations: 

 •  When multiple systems are running at the same time (Workshops), or when they’re running on long flows and other 
tasks could be started (multitasking). 

 •  When testing is complete but the system screen is out of view. 

Note:  Audible Notifications feature is disabled during testing by default. It can be switched on or off from the Main menu -> 
Settings tab -> Enable Audible Notifications During Testing, see the image below. 
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Audible Notifications during testing feature has three use-cases: 

1. When a test step has one of the following results: 

o Failed, if the test failure behavior is set to: 
i. ‘Manual’, the default registered windows exclamation sound is played upon displaying the ‘What 

to do?’ dialog box. 
ii. ‘Stop’, no audio is played. The audible notifications will be covered during test finishing flow in 

Step 2. 
iii. Any other failure behavior, the default registered Windows System Notification sound is played. 

o Warning, the default registered Windows Exclamation sound is played. This is for test steps which may 
only result in WARNING, and does not abide by the test failure behavior flows listed above. 

o Passed, no audible notification is played as this may cause constant distraction during testing. 

2. When a test is finished and the overall test result is: 

o Failed, the default registered Windows Critical Stop sound is played. 
o Warning, the default registered Windows Exclamation sound is played. 
o Passed, the default registered Windows Asterisk sound is played. 

3. When the whole testing process is complete and the message box containing "Test Complete" appears, PETS plays 
the default registered Windows NEW Mail Notification. 

Customizing the audible tones is available by changing their values from the Windows OS Sound Configuration dialog. To Open 
Windows OS Sound Configuration dialog, go to the personalization screen > sounds. The following dialog appears and new 
sounds can be mapped to the previous five registered sound names. 
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5.3.3 Viewing the Progress of a Test 

A summary of the progress of the test currently being run appears in the Steps pane.  

To display the Steps pane:  

Choose View > Steps Pane; the Progress pane appears under the test pane’s title bar. 

Detailed information about how a test is progressing can be obtained by clicking on the test to display its steps in the lower pane. 
The status of each test step appears in its Status column. 

Additionally, the status bar at the bottom of the Intel® PETS main screen displays the following information: 

• Network types and IP addresses for the SUT. 

• Local agent connection status (connected or disconnected) and the local Agent version installed on the SUT when the 
connection is active. This saves the time taken to open the SUT configuration window to test local agent 
connectivity. 

• System state: S0/G3 

• ME state: ME on, ME off 

• Power source: AC/ACDC/DC/G3 

• Time elapsed (the elapsed time for the current step is displayed in the status bar during execution in the following format: 
DD HH:MM:SS (DD - Days, HH - Hours, MM - Minutes, SS - Seconds).The progress timer starts counting from zero 
for each new test step until it has finished (or timed-out). The timer freezes if the test is paused, continues when 
running is resumed, is reset to zero if the step is retried, and stops if the test is aborted. 
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Detailed information about all the tests and test steps in the test package, while the package is being run can be obtained by: 

1.  Opening the test package’s test results log in the web browser (for information on how to locate the test results log, see 
Viewing the results of running a test package.) 

2.  Clicking the Refresh button in the web browser whenever requiring an update of the information in the report. 

The test’s status (Passed or Failed) appears in its Status column once all the test steps in a test have been run. If one or more 
steps end with the status Failed, the status of the test is changed to Failed. A message pops up when the test package finishes 
running displaying “tests completed”. 

 

 

Note:  The current SUT power status can be seen in the status bar. 

 

5.4 Viewing, Saving, and Sending Test Reports 
Once a test package finishes running, the results report of each test and each test step that was run can be seen. The report can 
be viewed in the Intel® Platform Enablement Test Suite or in the web browser. The reports have the same appearance and contain 
the same information regardless of the viewing location. 
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5.4.1 Viewing the results of running a test package 
The following information describes how a test package’s test results can be viewed: 

- The Run Test Results window appears in the Intel® Platform Enablement Test Suite window when performing one of 
the following actions: 
• Double-clicking a test’s Status field  

• Clicking on the Test results button in the toolbar ( ) 
• Choosing Report > View Reports. 

-  Double-clicking on the appropriate test result log in the web browser. The test results log files are located in <Intel(R) 
Platform Enablement Test Suite folder>\Logs. The location of the Intel® Platform Enablement Test Suite folder is set 
during the installation process. To make it easy to locate a specific log file, the format of the name of all test results log 
files is <package><date><time>.XML (e.g. Report-20090122124614.xml)  

 

 

 

5.4.2 Example 
Intel® PETS results for running Intel® DAL Compliancy test package on a LKF Consumer platform are updated in the excel sheet 
below.  

 

 

5.4.3 Report Viewer 
The Report Viewer allows easy navigation between reports by clicking on them in the left hand pane. It is possible to export PETS 
logs, import previously exported logs, and delete test result log files. Also, viewing, navigating, and selecting several older/newer 
logs is possible in the list prior to saving or copying them into other folders. Additionally, simultaneous export/import actions for 
multiple PETS logs is possible as well.  
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The Viewer includes the following information: 
- Statistics on the tests run. 
- Tests skipped (deselected ones). 
- Steps not run because they were deselected, or earlier failure/abortion of a step failed (clicking the stop button). 

Note:  Aborted tests may also include some failed tests. It is therefore recommended to view the PETS logs to check if any aborted 
tests actually failed before being aborted. 

- Information about the SUT on which the tests were run, including: 
o SUT Overview. 
o General Host Settings. 
o Power Settings. 
o Intel® PETS Power Provider Settings. 
o System Information. 

- Information is collected using the FWSTS Data Collection and SysScope Information tools. 
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Test Operator Additional Feedback upon Test Failure. 
‘Collect test operator data on failure’ feature is disabled by default. It is enabled it by checking “Collect Test Operator Data 
on Failure” checkbox under Settings in the Main Menu 

 
 

When enabled, regardless of the failure mode (except for Manual), a message box with a single input window appears allowing 
the test operator to add additional data about the failure at that point. 

 
 
For all Question/Answer test steps, the window above will not appear. Instead, a single input window will be added within the same 
message box that allows collecting of additional information at the time the test operator selects Yes/No, at all times. 
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For all Manual failure behavior tests, a single input window is added to the bottom of the “What to do” window allowing the test 
operator to provide additional data/information/observations about the failure at that point. 

 
 
In all cases above, the window will allow up to 1024 input characters. The test operator’s additional input will be copied into 
(appended to) the Intel® PETS log once the dialog box/message box hosting the input window is closed/cleared. 
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5.4.3.1 Importing Logs 

To import log files: 
1. Open the Report Viewer. 
2. Click Import Logs. 

 
 

3. The "Browse For Folder" window opens. Navigate to the log folder. 

 

 

Note:  An error will be received when trying to import PETS testing results from an empty directory or a directory that does not 
contain valid log files. 

 

 
Note:  When importing a log from a directory that already exists, a message appears informing the user that the "Log directory <dir 

name>” already exists. Do you want to overwrite it? This message only appears when the content in the directory conflicts 
with an existing one. 
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5.4.3.2 Exporting Logs 

To export log files: 
1. Open Report Viewer. 
2. Browse the report/s and select the log file/s you want to export from the list.  
3. Click Export Selected Logs. 

 

 
4. The Export Report Settings dialog opens. Set the desired export format from the following report formats: Standard 

PETS log (XML), HTML (Portable), or Excel Spreadsheet. 

 

5. Click Browse to set the Destination Directory. A dialog opens prompting you to select the target directory in which the 
logs are saved. Clicking Browse again sets the previously selected target directory to be the new default directory. 

6. Click OK. Intel® PETS saves the logs in the requested format in the target directory. 

Note:  Intel® PETS remembers the last destination a report export was saved to. 

Note:  Intel® PETS generates the HTML output and Spreadsheet only when choosing to export logs. They are not available by 
default in the “Logs\Log_XMLs” folder.  

When exporting an HTML report, the file can be shared with other people without consuming any extra resources and can 
view it using any Internet browser. This report captures all the test steps for each test.  

The HTML Report Type includes the following: 

- Information about the SUT on which the tests were run. 

-  System Scope information. 

- Management Console Information 

- General and Package Parameters  

-  Statistics on the tests run. 

-  Status for each test/s and steps. 

-  

Note:  Users can filter the test results on either the "test level" or "step level” in the same manner for both cases according to their 
ending results whether they are passed or failed. A tooltip will appear guiding the user to filter the test results accordingly.  
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Note:  Another tooltip will appear when pointing the mouse at the Passed and Failed results labels, prompting the user to click in 
order to filter the test results accordingly. For example, Clicking on “Passed” label as shown below, filters the test results to 
show only passed ones. The same applies for “Failed” test results label as well. 

 

Intel® PETS also allows users to export and view the Test Results Report in Excel spreadsheet format. You will see tabs for 
multiple sheets. 

- Pre-Work format sheet - Displays the test results in the pre-work format (only test case and sub tests are included).  
- Verbose format sheet - Holds a verbose version of the log (all test steps are included).  
- SUT Info sheet – Displays the System under Test information 
- MC Info sheet – Displays the Management Console information 



Running Tests with Intel® Platform Enablement Test Suite 

51 

Intel Confidential 

- Parameters sheet – Displays General and Package information

 

Note:  By default, Export Selected Logs and Delete Selected Logs are disabled until the user selects a log. 

Note:  When exporting a log/s from a directory that already exists, a message appears informing you that the "Log file <log file 
name>” already exists. Do you want to overwrite it? If “Yes” is clicked, the change will be applied to the current file only.  

On the other hand, clicking on “No” will skip the current file and “Cancel” will terminate the whole copy process. This 
message only appears when the content in the directory conflicts with an existing one. 

 
 

5.4.3.3 Deleting Logs 

To delete log files: 
1. Open Report Viewer. 
2. Browse the report/s and select the log file/s that you want to delete from the list. 
3. Click Delete Selected Logs.

 
 

4. When prompted for confirmation, click Yes. 
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5.4.4 Test Results Report SUT Information 

To display information about the SUT in the Test Results report: 
- Click the Show button at the top of the report. 

To hide information about the SUT in the Test Results report: 
- Click the Hide button at the top of the report. 

 

5.4.5 Test Results Report Test Information 
The Test Results Report provides a high level summary for each test. You can also view detailed information—as explained 
below. 

 You can filter the test results according to one the following criteria: 

- Failure Only: PETS only displays failed, aborted and conditionally passed tests. 

 

- Passing Only: PETS only displays tests that passed. 

 

- All: PETS displays all the tests (passed, failed, conditionally passed and deselected tests). 
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 To view more information on a specific test, click on it to see the following: 
A detailed secondary window appears that allows you to open the details of each step in the test, expand all, 
collapse all, or see all failures of that test. 

 

 You can also click the Compliancy Guide tab on this window to open this test in the Compliancy Guide. 
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5.5 Results Worksheet Generation 
The Results Worksheet is a new addition to Intel® Platform Enablement Test Suite that enables Intel® PETS users to update an 
excel sheet with the latest results of a set of tests performed on a defined SUT. This excel sheet provides statistics on the 
percentage of tests not performed, passing, failing, and blocked per SUT. Example and usage instructions are given below.  

5.5.1 Important notes 
The excel sheet template is not embedded into Intel® PETS. To get the template for Intel® CSME 12.0 based platforms, contact 
your CE representative. Excel templates for other Intel® ME projects will be available in the future. 

Please note that the results worksheet will be updated and saved in an excel file regardless if the console has Microsoft Excel or 
not. To be able to view the worksheet with all results statistics for your SUT, please make sure your console has Microsoft Excel. 

5.5.2 Usage 
Once Intel® PETS logs are ready, follow the steps below: 

1. Select “Generate Results Worksheet” option from the “Report” menu-bar item as seen below.  

 

2. Choose the desired SUT then import an excel template, where:  

a) SUT Name: The drop down menu shows information about user-defined SUTs currently available in in Intel® 
PETS. The selected option should belong to the desired SUT to generate the results sheet for. 

b) Excel Template: Click “Browse” to import the Microsoft Excel template file containing the set of tests and 
results to be updated.  

 

3. After importing is complete, the “Generate Results Worksheet” dialog will be updated with additional requested input 
for mapping with excel, where: 

a) Worksheet to Fill: The drop down menu shows options of all sheets in the imported excel template file.  
b) Test Name Column: Refers to the column name containing the list of tests. 
c) Result Column: Refers to the column name containing the test results to be updated 
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Note:  Click the Reset button to clear all input values. 

Note:  The input for mapping with excel will be updated automatically by Intel® PETS according to the imported excel file. The user 
might have to update these fiels manually if Intel® PETS cannot locate the “Test Name” or “Result” columns (i.e. value will 
be N/A). 

  

5.6 Using the Compliancy Guide 
 

Intel® Platform Enablement Test Suite allows you to display any test in the Compliancy Guide.  

Note:  This feature is supported in Internet Explorer 7 or above, and in Firefox 3 or above. 

To display the test in the Compliancy Guide: 

1. Right-click on any test in the PETS test pane.  

 The right-click menu opens. 

 

2. Select “Show Test In Compliancy Guide”. 

 The relevant test opens in the Compliancy Guide in a separate pop-up window. 
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6 Changing Package Parameters 
You can use the Package Parameters dialog to modify the time-out times, LPT Port, WLAN IP, WLAN Mac Address, and other 
parameters of a test package, to reflect the settings required for the specific system being tested.  

If you change a package parameter and then save the test package, the new settings will be used when you next open the 
package.  

To revert to the original default settings, navigate to the <PETS Installation Folder>\Packages\<Package 
Name>.xml.global file and delete it. When you subsequently open the package, it will use the original settings. 

Package Parameters are specific to each test package. Any changes in the Package Parameters do not affect the Package 
Parameters for any other package, even if they have the same name and meaning. Different packages have different lists of 
Package Parameters. 

6.1 Changing Parameter Values 

To open the Package Parameters dialog in Intel® Platform Enablement Test Suite: 

1. Open a test package. 

2. Choose Package > Package Parameters. 

 

To search for a package parameter: 

Go to the search box next to the “Search Parameter” label and type in the package parameter name that you’re looking for. 
The parameters will be filtered where the package parameters specification table will only show and highlight the 
parameters that have the user searched text in their name.  
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To change parameter values: 

Note:  The values of Package Parameters that are time-related are represented in seconds. 

1. Double-click the value of the parameter you want to change; the value is selected. 

2. Type in a new value for the parameter. 

3. Repeat steps 1-2 for all the parameters you want to change. 

4. Click OK. 

  

Please be aware that not all package parameters will be the same for all packages. 

To load package parameter default values: 

- Click "Load Defaults" and then "OK". 

Note:  By clicking Load Defaults, PETS resets the package parameter values to their original values (the initial values when PETS 
ran for the first time). Each package has its own parameters. 
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6.2 Test Step Parameters 

 

To load test step parameter default values: 

- Click Load Defaults and then OK. 

Note:  By clicking Load Defaults, PETS resets the test step parameter values to their original values (the initial values when PETS 
ran for the first time). If a parameter is shared between the test step and the package, the changes are reflected on both 
sides. 

To view step parameters: 

- Click the help icon beside in the Params column for steps that accept parameters. 

 

A window opens displaying the parameters related to the selected step (similar to that shown in Changing Parameter 

Values). You can view and change the parameter values as required. 
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7 Changing General Parameters 
 

The General Parameter dialog can be accessed through Settings > General Parameters menu item. 

General parameters are the parameters that are shared among all the packages in PETS. General Parameters are used to resolve 
the differences between different platforms supported by PETS. Modifications to one of the parameters will be affect all the steps 
that utilize it.  

You can use the General Parameters dialog to modify the general parameters listed in it. Currently, PETS defines some general 
parameters for the commonly used "BringToBase" step as shown in the image below: 

 

7.1 Changing General Parameter Values 

To modify the General Parameters: 
1. Double-click the value of the parameter you want to change; the value is selected. 

2. Type in a new value for the parameter. 

3. Repeat steps 1-2 for all the parameters you want to change. 

4. Click OK. 

To load general parameter default values: 
- Click Load Defaults and then OK. 

Note:  By clicking Load Defaults, PETS resets the general parameter values to their original values (the initial values when PETS 
ran for the first time). If a parameter is shared between the test step and the general parameters, the changes are reflected 
on both sides. 
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8 Running PETS in Package Design 
Mode 
Package Design Mode provides additional capabilities such as creating packages and tests from scratch, modifying existing tests, 
or adding extra tests and steps. 

Test steps are the building blocks for PETS test packages as they determine the specific functionality for each package. For 
example, you might need to ping the SUT as part of your test; a test step named “Ping” provides this functionality. If you need to 
add a delay after changing the SUT power state, you can use the “Delay” step to provide a delay with a configurable duration. 

PETS provides a large selection of out-of-the-box steps which are grouped into “Test Sets” depending on the functionality they 
provide. For example, the power steps can be found under the Power plug-in. 

Each step has a name, description, input parameters and output parameters. Sometimes, you might need to add a more specific 
description for the step depending on the functionality the step provides for your test. For example, the CMD step is a very 
general step used to run a command. After adding it as part of your test, you might wish to call it “Running the <Name of tool> 
tool” or “changing a setting” this will make your test easier to understand. 

You can filter the steps to get a specific plug-in step or use the free text search option to search for the step in all plug-ins and 
various tests or search for one in the Search Step bar. 
 

8.1 Creating a Blank Test Package 
You can create new packages and tests, add steps, and run the test. This enables you to run tests during package building and 
verify the results are as expected, and modify the test package as needed. 

To create a new test package: 
1. Choose Package > New. The Package Design Mode panel appears on the left side of the PETS interface. 

 
 

2. Add tests to your package, as described in the next section. 
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8.2 Adding Tests to a New Package 
1. Click Steps Kit > New Test. 

 
 

2. Right-click the test pane and select New. 

 

• The Test Properties window appears. 
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• The Required Features Window appears  

 

3. Enter a unique Name for your new test, add a Description, Required Features and click OK. 

4. The new test is loaded and displayed in the test pane. Add test steps, as described in the next section. 

5. Repeat this procedure whenever you wish to add a new test. 
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8.3 Adding Steps to the New Test 
Select Search Step under the Steps Kit tab. 

 

8.3.1 Configuring Step Properties 
You can edit the following step properties in the Properties tab of the Package Design Mode panel: 

- Step Description. 

- Failure Behavior - Enables you to instruct PETS how to proceed after a test step has failed. Possible values: 
{Inherit, Next Step, Next Sub Test, Next Iteration, Next Test, Stop, Manual}. 

- Use Local Agent - Indicates whether the step should be executed on the local agent (SUT). Possible values: 
{True, False}. 

- Sub Test Name - Indicates whether the selected step is the beginning of a sub test. (Sub test is another level of 
hierarchy and will result in GUI and reports). You only need to set this value for the first step in the sub test - do 
not configure this parameter for the other steps in the sub test. 

- Required features- shows different kinds of features  

- Setting Step Parameters – Each step has its own set of parameters depending on the functionality it provides. 
For example, the Ping step has the IP to ping and the Delay step has the total delay in seconds. For more 
information, refer Configuring Parameters. 
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Required Features let you Add Required Features to the selected test step in two ways: 

1. Either by writing the Required Features in the text box 
2. Or by clicking the Configure Feature(s) selection button wich will open the below window that enables you to 

choose Prerequisites from the list to be added to the selected test step. 

 

To add a step to a test: 

Select the step to be added and drag it from the Package Design Mode panel to the Test Steps Data Grid view, as shown in 
the following figure. 
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The step is added, the step IDs are rearranged, and the Steps Grid Header is updated. 
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8.4 Configuring Parameters 

8.4.1 Configuring Package Parameters 
When Package Design Mode is active you can modify, add, or remove any of the Package Parameters shown in the following 
figure.  
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8.4.2 Configuring Step Parameters 
1. Access the Properties tab of the Package Design Mode panel. 

2. Select a parameter to modify. 

3. Do one of the following: 

• Insert an immediate value. 

• Click on the Browse symbol next to the parameter and select a value from the Package Parameters or the previous 
Step Parameters tabs. 

 

8.5 Modifying Test Properties 
Right-click a test and select Properties. The Test Properties dialog appears, enabling you to change the test properties.  

The test is modified according to the user’s changes. 
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8.6 Cloning a Test 
You can clone tests within a package by creating copies of all the test steps, including step parameters, and applying the 
same settings. 

To clone an existing Test: 
1. Right-click the desired test and select Clone. 

 

 
2. Enter a unique name for the new test. 
3. The test and its steps are cloned, including all the step parameters. 

8.7 Removing a Test or Test Step 
1. Right-click the desired test/step and select Delete. 

 
2. The test/step is removed from the test list. The step IDs are rearranged and the Steps Grid Header is updated. 

Note:  If any following steps use the step you wish to delete, the system prompts you for confirmation before proceeding with the 
deletion. 

8.8 Moving a Test or Test Step Up/Down 
To rearrange (reposition) items within a test list: 

Drag and drop the desired test to the desired position in the list or right-click the test and select Move Up or Move Down. 
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Note:  If any following steps use the step you wish to reposition, the system prompts you for confirmation before proceeding with 
the move. 

8.9 Failure Behavior  
1. Right-click the desired test/step and select Failure Behavior  

 
2. The following tab for behavior options appears: 

 

Note: description for each behavior options are found in section 5.1.3 Using Intel®  Platform Enablement Test Suite 
Windows 

 



Running PETS in Package Design Mode 

70 

Intel Confidential 

8.10 Modifying an Existing Package 
You can modify an open package and apply the changes as needed. 

To edit an open/existing package: 
1. If the package is not open, choose Package > Open from the Package menu to open the package. 
2. From the main menu, choose Package > Edit 

 
3. From the Open window, select a package. 
4. Make the desired changes using the editing tools. 

Note:  The Edit Package option is only active if you have a package open in the GUI. 

 

8.11 Saving a Package 
When Package Design Mode is active, PETS checks if the package has been modified. In this case, PETS prompts you to save 
unsaved changes. 

To save the changed configuration of a test package as an original version: 

 •  Choose Package > Save. 
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Typically, you can use this function when editing an existing package and you wish to save changes as you work (prevent loss of 
information if a crash occurs). Save replaces the original file. 
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To save the changed configuration of a test package as a new version: 
1. Choose Package > Save As. 

 

 

 

When you have created a new package from scratch or you are basing the new package on one you have already 
opened/edited. This is useful if you want to save an existing package with a new name and then make changes rather 
than start from scratch. Save As leaves the original package unchanged. 

2. Enter the name of the new package in the Name field of the Save As dialog. 

3. Specify the desired location and click Save. The new version of the test package is saved in the desired 
location. 

Note:  PETS prevents you from saving an invalid package with a prompt message explaining the reason. The Package 
might be invalid for one of the following reasons: 

 •  A test in the package has steps that use an invalid or non-existent package parameter. 

 •  A test step is trying to read an input parameter from a step that does not exist. 
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9 Running Multiple Packages 
The PETS framework enables you to run multiple packages and save all the test results in an Excel file. This facilitates 
running automated tests overnight and reviewing the results when convenient.          

Note:  To use this feature, you must configure a SUT with APS 3.x and this should be initialized; in case it is not 
Configured correctly, the menu item Package > Run Multiple is disabled. 

To use run multiple packages: 
1. Click Package > Run Multiple. 

 
The Run Multiple Packages panel appears on the left side of the PETS interface displaying all the packages in the 
default directory of the selected SUT. 

 

2. Set the Packages Directory (where package/s XML files are stored) and Results Directory (where tests 
results are stored.) 
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3. Check Run automated tests only to run only automated tests or clear this option to run all the selected 
tests both manual and automated). 
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4. Select or deselect packages, drag-and-drop packages to change the order of execution, and click the Play 
icon. 

 

Note:  When you make changes to any package, the system prompts you for confirmation before proceeding. 
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PETS runs the packages and displays a progress bar beside each package. 

 

 

5. When a package has completed execution, you can click its status and open the standard PET results log. 

 

PETS creates Excel logs simultaneously and stores them by default in the Results folder nested under the 
packages folder. 
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 •  The Skipped status is displayed if the package has no automated test (all tests are manual) or if the 
tests have been deselected. 

 •  The Passed status is displayed if all the tests passed successfully. 

 •  The Failed status is displayed all package tests failed. 

 •  The Partially Failed status is displayed if some tests failed. 

 •  The Aborted status is displayed when the user clicks Stop. 

 •  The default value for the Packages Directory field is the default package folder for the selected SUT. 
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10 Intel® Platform Enablement Test 
Suite Package List  

10.1 Introduction 
This document lists the packages provided with Intel® Platform Enablement Test Suite, and includes the name of 
the XML file of each package. 

Note:  For most packages, each Test Name maps to the Test ID of a test in the Compliancy Requirements and Testing 
Guide. The exception is the Setup and Configuration package (SetupEnvironmentTest.xml); for details on the 
tests in this package.  

10.2 Package List 
Test packages are arranged by folders, as follows: 

 •  PCH. 
 •  Operating system (OS) for some platforms. 
 •  Firmware size. 
 •  Mobile. 
 •  Wireless_Only. 
 •  A full list of relevant packages and tests. 

 

The packages themselves bear simple names, whereas in the past their names reflected all of the above options. 
Below is a complete list of the packages that are included in different folders. Only packages relevant to that folder will 
be included, and only tests relevant to that folder will be included within the packages (i.e., a package in 2 different 
folders may not have the same contents, even if it has the same name). 

The Test Packages include: 
 •  Platform Controller Hub (PCH) SoftStrap Configuration  

(Compliance_PSS.xml). 
 •  Intel® Platform Trust Technology  

(Compliance_PTT). 
 •  SPI Flash Configuration 

 (Compliance_SpiFlashConfiguration.xml). 
 •  Intel® Management Engine BIOS Compliancy (Compliance_MeBios.xml) 

This package requires that Intel® APS to be connected to the system under test. 
 •  ME BIOS Manufacturing mode package (Compliance_MeBios_ManufacturingMode.xml) 

This test runs in pre-manufacturing mode. 
 •  Setup Environment Check of Intel® Platform Enablement Test Suite (SetupEnvironmentTest.xml) 

Checks ME Connectivity setup, Local Agent and SUT connectivity setup, and Intel® APS setup. 
Should be run after Intel® Platform Enablement Test Suite is installed and whenever the environment is 
changed. 
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This package requires that the Intel® APS to be connected to the system under test. 
 

Note:  For details on the tests in this package, see section: 5.4.1 "Testing the Configuration of the SUT". 
 •  Intel® Management Engine FW Power Management - BIOS Setting: S5 after Exiting G3 

(ME_Compliance_PM.xml)  
This package requires that Intel® APS to be connected to the system under test. 

 •  Integrated Clock Controller (ICC) - LP (Compliance_ICC_LKF) 
 •  Dynamic_Appl_Loader(Compliance_DAL) 
 •  Intel® Power Reset (Compliance_Power_ RST) 
 •  Intel® Boot Guard (Compliance_BootGuard) 
 •  Intel® ME Power Management Stress Test Coverage Summary (PM_Stress_Testing.XML) 
 •  Compliance_Dekel  
 •  Compliance_Dnx _blank 
 •  Compliance_Dnx_OSProvisioned  
 •  ISH FW Compliancy (Compliance_ISH) 
 •  Compliance_UFS_Blank  
 •  Compliance_UFS_OSProvisioned  
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